Google aclara el problema sobre los parches de seguridad en Jelly Bean

Es cierto que una compañía de la talla de Google, responsable del sistema operativo con mayor mercado a nivel mundial, deba continuar haciéndose responsable de las versiones anteriores a KitKat, pues la cifra representa un 61% de dispositivos Android que se quedarían sin parches de seguridad para el componente WebView.

Sin embargo, la compañía ha intentado aclarar este asunto y asegura que no es un problema que daba olvidarse de la nada, pues en vez de ello permitirán que la comunidad de desarrolladores proporcionen sus propios parches de seguridad, adjunto a un reporte, según informa Android Police. El viejo WebKit cuenta con 5 millones de líneas de código que no pueden modificarse sin tener el mayor cuidado, es por eso que la compañía optó por mejorar la forma en que ofrecían parches de seguridad para el componente desde KitKat.

Ahora es más clara la postura de Google en cuanto al abandono de Jelly Bean y versiones anteriores. Es mejor ofrecer consejos sobre seguridad y opciones a usuarios y desarrolladores, en vez de ofrecer los parches de seguridad, que se han lanzado siempre en conjunto con los fabricantes. A partir de que en KitKat se ha facilitado el desarrollo de parches, y no se diga en Lollipop, pues ahora se podrá actualizar directamente desde Play Store, es un hecho que esto tendría qué suceder sí o sí.

Google recomienda a los usuarios usar un navegador que no se vea afectado por los errores de WebView, como Chrome o Firefox, actualizados constantemente. Para los desarrolladores resultará ser más complicado, pues deberán tomar medidas para evitar las vulnerabilidades al usar WebView en versiones tempranas a Android 4.3, confiando en los sitios que usan el protocolo HTTPS en los sitios que pueden acaparar información importante.

Siguiente Noticia:
Noticia Anterior:

Comentarios